CRM - BlueRock Dialers are not running properly. We are working on a fix.
Incident Report for bittyadvance
Resolved
This incident has been resolved.
Posted Nov 28, 2022 - 13:01 EST
Investigating
We are currently investigating this issue.
Posted Nov 21, 2022 - 10:10 EST
This incident affected: CRM.