CRM - ERROR: Request failed with status code 502 with Notes and Histroy!
Incident Report for bittyadvance
Resolved
This incident has been resolved.
Posted Dec 17, 2023 - 18:00 EST
Investigating
We are currently investigating this issue.
Posted Dec 17, 2023 - 15:45 EST
This incident affected: CRM.