Contract - Documents page search not listing documents
Incident Report for bittyadvance
Resolved
This incident has been resolved.
Posted Oct 18, 2023 - 10:00 EDT
Investigating
Users may experience their documents not displaying on the Documents page when using search. We are working to resolve the issue as quickly as possible. Thank you for your patience.
Posted Oct 18, 2023 - 09:30 EDT
This incident affected: Contract.