Contract - Email delivery delays

Incident Report for bittyadvance

Resolved

This incident has been resolved.
Posted Jun 21, 2022 - 23:40 EDT

Update

Certain email providers are continuing to see mail delivery delays, but Google properties such as Gmail and Google Apps are delivering normally.
Posted Jun 21, 2022 - 18:40 EDT

Monitoring

We are currently experiencing delays with HelloSign email delivery to specific providers and are working to resolve the issue. HelloFax and HelloWorks email delivery is not affected.
Posted Jun 21, 2022 - 15:15 EDT
This incident affected: Contract.