CRM - Sync Delays

Incident Report for bittyadvance

Resolved

This incident has been resolved.
Posted Aug 19, 2025 - 23:00 EDT

Monitoring

There is a delay in data syncing to the MDC product. Information available in MDC may be missing or out of date until the delay has been resolved. We will report once the syncs have returned to normal.
Posted Aug 19, 2025 - 17:00 EDT
This incident affected: CRM.