Contract - Recent Dropbox Sign Security Incident
Incident Report for bittyadvance
Resolved
This incident has been resolved.
Posted May 16, 2024 - 16:01 EDT
Investigating
Some customers may be experiencing disruption as the result of a security incident. We sincerely apologize for the inconvenience. Please go here for more information here: https://sign.dropbox.com/blog/a-recent-security-incident-involving-dropbox-sign
Posted May 01, 2024 - 16:45 EDT
This incident affected: Contract.